json-lib 的 maven dependency 引入及Jar包下载

信息发布:soゝso 发布日期:2016-08-22 16:53 热度:1329 分享到:

当我们用 json-lib  的时候要引入依赖包,但是当我们用 Maven  的时候就会发现会报错。

json-lib  的 jar包下载和使用:http://www.sojson.com/blog/20

json-lib  的Java中json-lib的各种数据转换,及对象转换:http://www.sojson.com/blog/100

其他的  JSON  信息都在这里:http://www.sojson.com/tag_json.html

<dependency>
    <groupId>net.sf.json-lib</groupId>
    <artifactId>json-lib</artifactId>
    <version>2.4</version>
</dependency>

然后会报下面的错。

Missing artifact net.sf.json-lib:json-lib:jar:2.4:compile

那怎么解决呢?因为 json-lib  依赖的是 jdk  1.5,如果我们用的 JDK  不是1.5版本,就会报错。那么我们要指定 JDK  的版本。

<dependency>
    <groupId>net.sf.json-lib</groupId>
    <artifactId>json-lib</artifactId>
    <version>2.4</version>
    <classifier>jdk15</classifier>
</dependency>

如上面这样引入,就OK了。

需要依赖的Jar包是这些:

json-lib-2.4-jdk15.jar
commons-beanutils-1.8.0.jar
commons-logging-1.1.1.jar
commons-collections-3.2.1.jar
commons-lang-2.5.jar
ezmorph-1.0.6.jar

如果不用 Maven  ,请于附件下载 json  依赖jar包


附件下载

json-lib依赖jar包.zip

备注:点击文件名下载,附件源来自云端,只能在本站下载。复制下载链接无效。

本文主题

如果本文对你有帮助,那么请你赞助我,让我更有激情的写下去,帮助更多的人。

¥我需要走的更远,点击我 赞助。 如果还有疑问,点击我加群,为你提供最好的解答。


工具导航地图

 
Nodejs + socket Demo 赞助二维码 赞助名单 百度口碑点赞 查看QQ群美女帅哥 点击加QQ群 听音乐 开启弹幕 X
反馈意见